站长视角
用户至上

部署https后访问提存在安全隐患NET::ERR_SSL_OBSOLETE_VERSION

image.png

部署https后访问域名出现如下提示:

您的连接存在安全隐患

此网站使用的安全性配置已过时,这可能会导致您的信息(例如密码、消息或信用卡卡号)在发送至此网站的过程中遭到泄露。

 

NET::ERR_SSL_OBSOLETE_VERSION

原因是服务器openssl版本过低,较新版本的浏览器会提示不安全,

openssl version -a可查看openssl版本

Openssl 1.0.0h支持SSLv2,SSLv3和 TLSv1.0

Openssl 1.0.1添加了对TLSv1.1和TLSv1.2的支持
Openssl 1.1.1开始支持TLS1.3

旧版(openssl1.0.2|openssh7.5)升级

升级openssl-1.1.1

cd /usr/local/src
wget -c https://www.openssl.org/source/openssl-1.1.1g.tar.gz
tar zxvf openssl-1.1.1g.tar.gz
cd openssl-1.1.1g
./config --prefix=/usr --shared
make -j4 && make install
openssl version -a

升级openssh8.3p1

cd /usr/local/src
mv /etc/ssh /etc/ssh.bak
yum install -y pam-devel
wget -c https://openbsd.hk/pub/OpenBSD/OpenSSH/portable/openssh-8.3p1.tar.gz
tar zxvf openssh-8.3p1.tar.gz
cd openssh-8.3p1
./configure --sbindir=/usr/sbin/  --bindir=/usr/bin/ --sysconfdir=/etc/ssh  --with-ssl-engine --with-pam
make -j4 && make install
echo 'PermitRootLogin yes' >> /etc/ssh/sshd_config
echo 'Port 22000' >>/etc/ssh/sshd_config
cp -a contrib/redhat/sshd.init /etc/init.d/sshd
cp -a contrib/redhat/sshd.pam /etc/pam.d/sshd.pam
chmod +x /etc/init.d/sshd
chkconfig --add sshd
chkconfig sshd on
service sshd restart

centos7: mv  /usr/lib/systemd/system/sshd.service  /tmp

systemctl enable sshd

centos7: systemctl restart sshd.service

image.png

注意: 如果nginx编译时指定了自定义openssl路径,则还需要重新编译nginx

赞(0) 打赏
版权声明:本文采用知识共享 署名4.0国际许可协议 [BY-NC-SA] 进行授权
文章名称:《部署https后访问提存在安全隐患NET::ERR_SSL_OBSOLETE_VERSION》
文章链接:https://www.sshce.com/13239.html
本站资源仅供个人学习交流,请于下载后24小时内删除,不允许用于商业用途,否则法律问题自行承担。
标签:

觉得文章有用就打赏一下文章作者

支付宝扫一扫打赏

微信扫一扫打赏